sexta-feira, 2 de março de 2012

Fórmulas - Contar se

A fórmula CONTAR.SE pertence à estatística  e pode ser-nos bastante útil, para contar o número de células que respeitam uma determinada condição. Assim, podemos ficar a saber quantos alunos, por exemplo, entraram no 1º ano ainda com 5 anos, quantos alunos tiveram nota positiva num teste, quantos alunos erraram uma determinada questão, quantos alunos têm Internet em  casa, etc, etc.
Para inserir a fórmula procede-se exatamente da mesma maneira como para a fórmula CONTAR.VAL.
Ou se escreve sinal igual seguido de um C e aparece-nos logo a lista de fórmulas iniciadas com C, entre as quais a CONTAR.SE. Ou então vamos a "fórmulas", "estatística" e  escolhe-se CONTAR.SE.
No exemplo seguinte, para saber quantos alunos tiveram nota positiva num exame e ficaram aprovados ou reprovados, pode-se fazer de duas maneiras: ou se toma em consideração a nota quantitativa (se teve nota igual ou superior a 50%) ou a qualitativa (se ficou "aprovado" ou "reprovado").

  • A fórmula deverá ficar sempre assim: =CONTAR.SE(intervalo;"critério").
  •  Nestes exemplos ficaria =CONTAR.SE(B3:B12;">=50"); =CONTAR.SE(B3:B12;"<50"); =CONTAR.SE(C3:C12;"aprovado") ou =CONTAR.SE(C3:C12;"reprovado")
  • O critério deverá ficar entre aspas e deverá ser escrito como está no documento, mas não faz diferenciação entre a miúscula ou minúscula inicial;
  • O intervalo de valores separa-se do critério com ponto e vírgula.
  • Pode parecer difícil, mas é fácil, basta experimentar!

Sem comentários:

Enviar um comentário